Not resolved
1 comment

On May 19, 2008 my husband and I bought a utility shed at the Olathe, KS location. It had a rebate form for $55.00, credit back for delivery. I filled out the receipt and mailed it the very next day.

I checked the on line status of my rebate and it said there was no record of submission. I sent an email to the website and received an email from “Cyber Rep” asking for information that was on the receipt I had mailed in and said give it another 2 -3 weeks. I still have not received my money and it's been almost 3 months.

That's false advertisement and fraud!

Company wrote 0 private or public responses to the review from Jul 16, 2008.
Do You Have Something To Say ?
Write a review

Comments

Terms of Service
Post Comment
Cancel
Anonymous
Alcala De Henares, Madrid, Spain #25411

Did you follow up on the return email? Cyber Rep is the designation for people working on the email team, if you haven't received anything from us it's because either it was lost or damaged in the mail. The rep was asking for you to provide more information so they can do a more thorough search of our extensive records (the is close to a billion submissions in our database).

Assuming you followed the correct procedure when sending you rebate and your taking the initiative to try to clear up the issue with us, there should be no problem getting this fixed up.

Contrary to popular belief those of us working at the rebate center do not go out of our way to disqualify consumers, do you any idea how much easier it is when we can just say "Yea, I can get that resolved for you" than to have to sit and argue for 20 minutes about why we can't.

You May Also Like